www.DRRiders.com

A Dedicated Suzuki DR650 forum for DR650 riders to share their knowledge, experience and adventures!
It is currently Mon Oct 23, 2017 7:40 am

DRRIDERS.COM Search - powered by Google

DRRIDERS Member Location Map

Place yourself on the map here!

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Sun Sep 17, 2017 11:36 am 
Offline
Newbie
Newbie

Joined: Tue Jul 25, 2017 1:24 pm
Posts: 7
Location: Ventura, CA
I’ve got a 2000 DR650 with 23k miles that has been my daily/camping bike for the last 4 years. I consider myself pretty capable mechanically (rebuilt/restored other bikes as well), but this problem has me stumped. Here’s what happened:

The bike was running normally, then sat for two months while I traveled (a friend was supposed to ride it, but oh well). I got back, put on some new brake pads and took it for a spin to bed-in the brakes. The bike was running well, I was having fun, and I sped up to 90mph on my way back home (it’s got a modified airbox, rejetted BST40 carb and GXSR exhaust…normally does 90 easy). All of a sudden the motor starts cutting out, I back off the gas and pull in the clutch, and the motor dies. Tried to start it again on the side of the road, no luck. When I try to start the bike, the starter motor cranks, the piston cycles, I have spark, but it will only fire for a millisecond and then die (maybe on just one stroke) after cranking for 4-5 seconds. Here’s what I’ve done so far:

* Did a leakdown test, looked great at 95%
* Changed oil, no metal shards found on magnetic drain plug or in pan
* Cleaned carb
* Drained old gas from tank, replaced with fresh gas and added fuel stabilizer
* Adjusted valves (they were a tiny bit loose)
* Replaced spark plugs (checked them on the bike, getting consistent bright blue sparks)
* Tested resistance of pulsar coil, power coil, and ignition coil (both primary and secondary) - all within spec
* Battery tested and in good shape

After all this, I still have the same result when starting the bike. I haven’t tested the CDI box yet, but I think that’s the next thing on my list before tearing into the motor. Any ideas of where else to go from here? This really has me banging my head against the wall...


Top
 Profile  
 
PostPosted: Sun Sep 17, 2017 11:48 am 
Offline
Trail Rider
Trail Rider

Joined: Fri Dec 18, 2015 11:09 pm
Posts: 104
Location: Matawan, NJ
Doese it get fuel? Clogged fuel filter, especially the factory screen filter. Aftermarket tank? Bad cap vent?


Top
 Profile  
 
PostPosted: Sun Sep 17, 2017 11:58 am 
Offline
Newbie
Newbie

Joined: Tue Jul 25, 2017 1:24 pm
Posts: 7
Location: Ventura, CA
mariom1 wrote:
Doese it get fuel? Clogged fuel filter, especially the factory screen filter. Aftermarket tank? Bad cap vent?


When I drained the old gas, I let it out through the petcock and through my inline fuel filter...seemed to flow just fine. I've got an IMS tank, FYI. Maybe I'll check that again, but I thought it should start just from the fuel in the float bowl.


Top
 Profile  
 
PostPosted: Sun Sep 17, 2017 5:37 pm 
Offline
Adventure Rider
Adventure Rider
User avatar

Joined: Sat Mar 17, 2012 5:31 pm
Posts: 3776
Location: Central Florida, Where the clueless go to drive...
How old are your float assembly o-rings? Could be over filling the floatbowl if they are leaking. Cheap to change.

_________________
Dave
Spaced Coast, FL
So what is the speed of dark?


Top
 Profile  
 
PostPosted: Sun Sep 17, 2017 7:44 pm 
Offline
SuperMoto Dude
SuperMoto Dude

Joined: Wed Jul 22, 2015 7:58 am
Posts: 349
Location: Perth,W.A. Australia
Side stand switch ?

_________________
Mick


Top
 Profile  
 
PostPosted: Sun Sep 17, 2017 9:02 pm 
Offline
Newbie
Newbie

Joined: Tue Jul 25, 2017 1:24 pm
Posts: 7
Location: Ventura, CA
Sandcrabdave wrote:
How old are your float assembly o-rings? Could be over filling the floatbowl if they are leaking. Cheap to change.


Old, probably really old. When I cleaned and reassembled the carb, the float assembly wasn't seating very well in the two openings in the carb body, so I thought my float height measurement could be a bit off. Already ordered a carb rebuild kit though, so I'll put them in when they get here in a few days. Good thinking, will update you once I get them installed. Thanks!


Top
 Profile  
 
PostPosted: Sun Sep 17, 2017 9:04 pm 
Offline
Newbie
Newbie

Joined: Tue Jul 25, 2017 1:24 pm
Posts: 7
Location: Ventura, CA
faded wrote:
Side stand switch ?


If the side stand switch isn't working properly, wouldn't it stop the starter motor from cranking? Mine is cranking just fine, just not firing...


Top
 Profile  
 
PostPosted: Wed Sep 20, 2017 6:15 am 
Offline
SuperMoto Dude
SuperMoto Dude

Joined: Wed Jul 22, 2015 7:58 am
Posts: 349
Location: Perth,W.A. Australia
bryanseeee wrote:
faded wrote:
Side stand switch ?


If the side stand switch isn't working properly, wouldn't it stop the starter motor from cranking? Mine is cranking just fine, just not firing...

Of coarse... Maybe take out the plugs after you try cranking with open throttle to see if they have fuel on them... Sounds like carby issues. But I'm no guru...

_________________
Mick


Top
 Profile  
 
PostPosted: Wed Sep 20, 2017 7:45 am 
Offline
MSF Student
MSF Student

Joined: Wed Dec 31, 2014 2:01 am
Posts: 70
Location: Somerville , Australia
Location:
If the plugs do spark that is good but are the plugs wet or dry after trying to start it ?

Dry plugs normally signify no fuel, wet plugs means you are getting fuel but either no spark or incorrect spark timing, CDI fault or pick up coil etc.

Make sure the pilot jet is spotless clean and blow out every air passage with compressed air, one tiny speck can cause no fuel flow.


Top
 Profile  
 
PostPosted: Wed Sep 20, 2017 8:11 am 
Offline
SuperMoto Dude
SuperMoto Dude

Joined: Tue Mar 15, 2011 9:22 am
Posts: 406
Location:
cdi IMHO

_________________
1996 DR650SE Street Tracker 19" front, K&N filter, Bad Ass FCR39

Athens Greece


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  



Forum hosting by ProphpBB | Software by phpBB | Report Abuse | Privacy